حل لمشكل ظهور خطأ في ملف includes\file.inc لدى محاولة تنصيب Drupal 6.14 على EasyPHP 5.3.0

حل لمشكل ظهور خطأ في ملف includes\file.inc   لدى محاولة تنصيب Drupal 6.14 على EasyPHP 5.3.0

السلام عليكم

صادفتني مشكلة لدى محاولة تنصيب Drupal 6.14 على EasyPHP 5.3.0  حيث أنه بمجرد الدخول إلى مجلد الـ Drupal  تظهر رسالة الخطأ التالية

Deprecated: Function ereg() is deprecated in F:\Program Files\EasyPHP5.3.0\www\drupal-6.14\includes\file.inc on line 902

172 مرة

قمت بعملية بحث سريعة على النت و وجدت الجواب على موقع Drupal و المتمثل في التالي:

استبدال السطر902 الذي يحتوي على

elseif ($depth >= $min_depth && ereg($mask, $file)) {

بـ

elseif ($depth >= $min_depth && mb_ereg($mask, $file)) {

في الملف includes/file.inc

و من ثم حفظ التغيرات  و إعادة عملية التنصيب من جديد

و السلام عليكم

2 thoughts on “حل لمشكل ظهور خطأ في ملف includes\file.inc لدى محاولة تنصيب Drupal 6.14 على EasyPHP 5.3.0

التعليقات مغلقة.